Podio Google Maps Street View FIXED!!! (and why it's not working)

1 Reply

Many of you using Podio may have noticed that your Google Street View Map has stopped working recently! You're probably getting an error that looks like this...

I did some quick research and it turns out, that Google has recently made some changes. It seems you must now have API(s) set up via Google Cloud Platform in order for this to work.

See this link to set it up: https://cloud.google.com/maps-platform/user-guide/...

To fix this in your Podio, or other CRM, you need to do the following.....

Google Maps API Set Up:

1. Initiate your Google Cloud Platform by clicking the I posted above. (Here it is again: https://cloud.google.com/maps-platform/user-guide/... )

2. Create a New "Project" and add the "Street View API"

3. Set up Billing for the new Project (In the Overview section at the bottom left)

4. Select APIs from the Dashboard on the left and then select "Street View API" to open the API details

5. Click on the "Credentials" tab and then click the "Create credentials" button (If given the option, create credential as an "API Key")

6. Copy the API Key

Podio Fix:

1. Go to Modify Template in the application where your Google Street View Map is.

2. Select that field and change it to the following: 

If you want to copy and paste:

var prop = @Formatted Address;

"![alt-text](https://maps.googleapis.com/maps/api/streetview?size=600x300&location=" + prop + "&fov=70&key=YOURAPIKEY)"

*Note:

-Where it says, "@Formatted Address", you will need to replace it with the field that references the property address.

-Where it says, "YOURAPIKEY", you will replace it with the API Key that you just created from your Google APIs Page.

I hope this helps some people out. Feel free to reach out to me if you have any questions.

--

Cory Bittick | Founding Partner

Linchpin REI, Inc.